Справка DIGIMINE

Главное меню окна для работы с таблицами БД

Главное меню окна для работы с таблицами БД

Previous topic Next topic  

Главное меню окна для работы с таблицами БД

Previous topic Next topic  

 

Главное меню окна содержит следующие пункты:

 

 

В главном меню нет дублирования тех пунктов меню, которые есть во всплывающих меню, а также нет пунктов меню, дублирующих элементы графических меню.

 

Пункты меню Мозаика из 2-х окон, Окно, Справка аналогичны соответствующим пунктам меню при работе с графическими окнами и в данном разделе не рассматриваются.

 

Кроме того, следующие вложенные пункты пункта меню Файл, также аналогичны соответствующим пунктам меню при работе с графическими окнами – Новый файл, Открыть файл, Открыть проект…, Сохранить проект, Сохранить проект как…, Выход без сохранения проекта и Выход.

 

Вложенные пункты пункта меню Файл:

 

Новый файл – создание нового файла (не только файла БД) – вызов диалога "Выбор типа нового файла".

 

Открыть файл - открыть существующий файл.

 

Открыть проект… - открыть существующий файл проекта. Файлы текущего проекта будут закрыты с проверкой, сохранены ли изменения, сделанные в этих файлах.

 

Сохранить проект - запись на диск файла проекта и всех измененных рабочих файлов.

 

Сохранить проект как… - запись на диск файла проекта под другим именем, а также и всех измененных рабочих файлов.

 

 

 

Импорт из текстового файла – далее выбирается в какую таблицу будет производиться импорт из текстового файла:

 

 

 

Импорт из dm-файла Datamine - далее выбирается в какую таблицу будет производиться импорт из dm-файла Datamine:

 

 

 

Экспорт в текстовый файл... – вызов диалога "Экспорт в текстовый файл" для настройки параметров экспорта из какой-либо таблицы БД.

 

 

Экспорт в dm-файл Datamine... – вызов диалога "" для настройки параметров экспорта из какой-либо таблицы БД.

 

 

Выход без сохранения проекта – выход из программы без сохранения файла проекта. Файлы текущего проекта будут закрыты с проверкой, сохранены ли изменения, сделанные в этих файлах.

 

Выход - выход из программы с записью на диск файла проекта. Файлы текущего проекта будут закрыты с проверкой, сохранены ли изменения, сделанные в этих файлах.

 

 

 

Вложенные пункты пункта меню Правка:

 

Выделить выработки… - вызывается диалог "Выделение выработок", в котором задается формула для выделения выработок.

 

Снять выделение выработок – снимается признак выделения (записывается 0) для всех выделенных выработок.

 

Удалить выделенные выработки – удаляются выделенные выработки.

 

Удалить невыделенные выработки – удаляются невыделенные выработки

 

 

 

Вложенные пункты пункта меню Сервис:

 

 

 

 

Разнести устья выработок по разрезам – программа для каждой выработки определяет разрез (из текущего загруженного списка разрезов), в зону влияния которого попадает устье выработки и записывает название этого разреза в обязательный столбец "Разрез" таблицы со списком выработок. В том случае, когда устье выработки попадает в зону влияния нескольких разрезов, записывается тот разрез, который раньше встречается в справочнике разрезов.

Кроме рассматриваемого обязательного столбца "Разрез", в базе данных обычно присутствует и столбец "Разрез ввод", в который пользователь вводит название разреза, к которому выработка была отнесена в процессе разведки. Различные названия разрезов в этих двух столбцах может указывать на ошибку в исходных данных.

 

 

Добавить инклинометрию на расстоянии 0м… - вызывается диалог "Добавление инклинометрии на расстоянии 0 м".

Для некоторых программ требуется наличие замера инклинометрии в точке, находящейся на расстоянии 0м от начала выработки.

Кроме того, можно занести инклинометрию для [коротких] выработок, по которым инклинометрия, как таковая, не вводится.

 

 

Добавить 'пустой' интервал в конец таблицы… - вызывается диалог "Добавление 'пустого' интервала в конец таблицы".

Используется в тех случаях, когда требуется сделать так, чтобы  расстояние до конца последнего интервала в заданной таблице совпадало с введенной длиной выработки.

 

 

Пересчитать координаты (или углы) инклинометрии – при выборе одного из вложенных пунктов меню  происходит пересчет инклинометрии либо по текущей выработке, либо по выделенным выработкам, либо по всем выработкам базы данных.

Если инклинометрия какой-либо выработки введена углами (азимут и вертикальный угол), производится вычисление координат точек замера инклинометрии, если инклинометрия введена координатами, то производится вычисление углов и расстояний до точек инклинометрии.

В процессе ввода и редактирования инклинометрии, в том числе при редактировании в графическом режиме, все пересчеты выполняются автоматически. Использование рассматриваемых пунктов меню необходимо только в том случае, когда нужно пересчитать инклинометрию с использованием другого алгоритма. Пересчет инклинометрии для выработки производится по тому алгоритму, который является текущим, что задается в графическом меню - .

Для того чтобы изменить алгоритм инклинометрии, например, по всем выработкам необходимо сначала установить в графическом меню требуемый алгоритм инклинометрии, и, затем, выбрать пункт меню "Сервис/Пересчитать координаты (или углы) инклинометрии/Всех выработок".  После этого произойдет изменение алгоритма инклинометрии и пересчет инклинометрии для всех выработок.

Для рассматриваемого пункта меню операция отмены редактирования не предусмотрена.

 

Пересчитать истинный азимут по магнитному – при выборе одного из вложенных пунктов меню  происходит пересчет истинных азимутов по магнитным азимутам с применением текущего магнитного склонения  либо по текущей выработке, либо по выделенным выработкам, либо по всем выработкам базы данных.

Пересчет выполняется только для тех интервалов инклинометрии, для которых введено значение магнитного азимута. Для интервалов, по которым имеется только истинный азимут, пересчет не выполняется.

Для рассматриваемого пункта меню операция отмены редактирования не предусмотрена.

 

 

 

Поиск пересекающихся интервалов – инициализируется поиск "пересекающихся" интервалов (в двух разных таблицах). В некоторых случаях требуется, чтобы начала (концы) интервалов в одной таблице точно совпадали с началами (концами) интервалов в другой таблице.

 

 

 

 

Заменить в названиях символы кириллицы на латинские – производится замена всех символов кириллицы в названиях выработок на латинские символы (слева символы кириллицы, справа – латинские):

а = a     б = b     в = v     г = g     д = d     е = e      ё = e     ж = j     з = z     и = i     й = y     к = k

л = l     м = m     н = n     о = o     п = p     р = r      с = s     т = t     у = u     ф = f     х = h     ц = c

ч = c     ш = s     щ = s     ъ = q     ы = y     ь = q     э = e     ю = u     я = w

Аналогичные замены производятся и для прописных символов.

 

 

Преобразовать координаты выработок – вызывается диалог "Преобразование координат выработок БД", в котором задаются параметры смещения/поворота выработок БД:

 

 

 

Ввод/изменение пароля БД… - вызывается диалог "Ввод/изменение пароля", в котором задается или изменяется пароль БД:

Пароль используется при разблокировании таблиц и столбцов БД от удаления или редактирования.

 

 

Пересчитать расчетные столбцы всех выработок - В процессе редактирования таблиц программа автоматически отслеживает, какие расчетные столбцы (и таблицы) должны быть пересчитаны. Поэтому задавать пересчет расчетных столбцов вручную обычно не нужно. Рассматриваемый пункт меню оставлен в программе только на непредвиденный случай, если вдруг обнаружится, что автоматический пересчет не выполнен.

 

Выполнить преобразования редактируемого столбца... - вызывается диалог "Выполнить преобразования в редактируемом столбце при помощи формулы", в котором можно задать формулу для изменения содержимого в редактируемом столбце.

Формула аналогична формулам, используемым в расчетных столбцах. Только в расчетных столбцах при изменениях исходных данных автоматически производятся пересчеты, а в рассматриваемом случае производится однократное применение формулы к заданному редактируемому столбцу.

 

 

Получить интервалы по заданным условиям... - вызывается диалог "Выбор интервалов (строк) по заданным условиям", можно произвести выборку интервалов (или строк из таблицы со списком выработок) по заданным условиям.

 

 

 

Получить исходные интервалы для рудных... - вызывается диалог "Формирование таблицы исходных интервалов для рудных интервалов", в котором можно подготовить и записать в текстовый файл или буфер обмена Windows таблицу, в которой для каждого рудного интервала выбираются исходные интервалы опробования (заданные столбцы из таблицы с исходными интервалами опробования).

Подобные таблицы часто требуются при подготовке отчетных материалов к подсчету запасов.

 

 

Анализ интервалов… - вызов диалога "Статистика по столбцу из базы данных", в котором можно произвести различного рода выборку и группировку информации по столбцу БД.

 

 

Расчет рудных интервалов для разных параметров кондиций... - вызывается диалог "Расчет рудных интервалов для разных параметров кондиций" для того, чтобы задать параметры кондиций (бортовое содержание, минимальную мощность рудных тел, максимальный безрудный прослой) с заданным шагом и получить показатели рудных интервалов, получаемых при разных вариантах кондиций, в виде таблицы.