Справка DIGIMINE

Виртуальные полилинии и точки

Виртуальные полилинии и точки

Previous topic Next topic  

Виртуальные полилинии и точки

Previous topic Next topic  

 

Виртуальные полилинии/точки появляются в 2D окнах разреза или плана.

 

Виртуальные полилинии/точки формируются программой непосредственно перед отрисовкой объектов из файла-чертежа или из файла с моделями поверхностей и выводятся в окно.

То есть, в самих файлах-чертежах или файлах с моделями поверхностей виртуальных полилиний/точек нет и с ними невозможно выполнять какие-либо операции, т.к. после выполнения отрисовки в окне они сразу же удаляются.

 

Виртуальные полилинии/точки получаются при пересечении плоскости текущего окна с имеющимися объектами в файлах-чертежах или в файлах с моделями поверхностей.

Когда изменяется плоскость текущего 2D окна (например, при изменении текущего разреза), виртуальные полилинии изменяются.

 

При необходимости можно преобразовать виртуальные полилинии в реальные и записать их в текущий файл-чертеж. После этого с ними можно работать как с обычными полилиниями.

 

Не все объекты из файлов-чертежей участвуют при формировании виртуальных полилиний/точек. Например, виртуальная полилиния типа Разрез дневной поверхности формируется только при наличии в файле-чертеже полилиний типа Горизонталь дневной поверхности.

 

 

 

Виртуальные полилинии, генерируемые для полилиний некоторых (фиксированных) типов в файлах-чертежах

 

К виртуальным (вычисляемым) полилиниям, получаемым при обработке файлов-чертежей относятся линии следующих типов:

- Разрез дневной поверхности;

- Разрез карьера;

- Разрез оптимального карьера;

- Разрез рельефа оптимального карьера.

 

 

Если в файле-чертеже имеются полилинии типа Горизонталь дневной поверхности, то в окне разреза будет сформирована полилиния типа Разрез дневной поверхности, представляющая собой разрез по горизонталям дневной поверхности. Эта полилиния мнимая и не может быть подвергнута редактированию напрямую (в окне разреза).

 

 

 

 

Если в файле-чертеже имеются изолинии типа Изолиния оптим. карьера на разные даты (этапы отработки), то полилинии типа Разрез оптимального карьера строятся для каждой даты отдельно. На рисунке приведен график отработки оптимального карьера на разрезе (все этапы) и в плане (только 7 этап).

 

 

 

 

 

Полилиния типа Разрез карьера формируется в окне разреза с учетом имеющихся полилиний типов Верхняя бровка, Нижняя бровка, Начало съезда, Конец съезда, Разделение уступов и Разделение съезда.

 

Так же, как для полилиний оптимального карьера, полилиния типа Разрез карьера отстраивается для каждой даты отдельно.

 

Имеется возможность производить отстраивание разреза карьера без учета дат и линий разделения уступов и сьездов. Данные опции задаются в диалоге "Параметры отрисовки объектов файлов-чертежей", вызываемом при выборе пункта меню Вид / Линии, полигоны, отметки …

 

 

 

 

Виртуальные полилинии / точки, генерируемые для объектов, принадлежащих горизонтам в окнах разрезов и для объектов, принадлежащих разрезам, в окнах плана

 

 

 

Полилинии/полигоны в файлах-чертежах могут принадлежать горизонтам, разрезам или документу.

 

Если полилиния принадлежит горизонту, то, по умолчанию, в окнах разрезов она не отображается.

При необходимости можно задать, чтобы она либо просто рисовалась в окнах разрезов, либо рисовалась не сама полилиния, а точка пересечения полилинии с плоскостью разреза :

 

В последнем случае программа генерирует и выводит в окно разреза виртуальную точку пересечения полилинией плоскости текущего разреза (если такая точка имеется).

Полученные в окне разреза точки являются виртуальными, с ними нельзя выполнять операций редактирования.

 

Аналогичная ситуация и для полилиний, принадлежащих разрезам, применительно к окнам плана.

 

 

 

Для полигонов, имеющихся в файлах-чертежах, производится генерация не точки, а линии пересечения полигоном плоскости текущего разреза:

Полученные в окне разреза линии являются виртуальными, с ними нельзя выполнять операций редактирования.

 

 

 

Для преобразования виртуальных полилиний / точек, полученных в процессе обработки файлов-чертежей и записи таких полилиний в текущий основной файл-чертеж необходимо выбрать пункт меню Сервис / Файл-чертеж (mn4) / Записать линии, получившиеся в окне разреза, в основной файл или Сервис / Файл-чертеж (mn4) / Записать линии, получившиеся в окне плана, в основной файл.

 

 

 

 

 

 

Виртуальные полилинии, генерируемые для моделей поверхностей

 

 

В 2D окнах модели поверхности могут рисоваться либо в виде проекции всех треугольников моделей поверхностей на плоскость текущего окна, либо в виде среза поверхностей плоскостью текущего горизонта или разреза:

 

 

 

 

Если в задана отрисовка в виде среза, то в окне разреза или плана формируется полилиния, имеющая тип Разрез поверхности dgs:

 

 

 

Для преобразования виртуальных лилиний, полученных в процессе обработки файлов с моделями поверхностей и записи таких полилиний в текущий основной файл-чертеж необходимо выбрать пункт меню Сервис / Модели поверхностей (dgs) / Записать линии, получившиеся в окне разреза, в основной файл или Сервис / Модели поверхностей (dgs) / Записать линии, получившиеся в окне плана, в основной файл.