Справка DIGIMINE

Запись объектов БД в файл-чертеж

Запись объектов БД в файл-чертеж

Previous topic Next topic  

Запись объектов БД в файл-чертеж

Previous topic Next topic  

 

При оформлении чистовых чертежей иногда возникает проблема наложения друг на друга различных объектов, выводимых на печать из базы данных. Прежде всего, это касается различных надписей. Имеющиеся настройки отрисовки позволяют уменьшить количество проблем, но при высокой степени насыщенности чертежа информацией некоторые  наложения остаются.

 

Информацию, выводимую из БД в рабочее графическое окно, можно представить, в конечном итоге, в виде набора разнообразных полилиний, полигонов и текстовых надписей.

В DigiMine имеется механизм, позволяющий преобразовать и записать в файл-чертеж информацию, выводимую в конкретное рабочее графическое окно, в виде упомянутых полилиний, полигонов и текстов. Далее с полученными объектами можно производить различные манипуляции с целью получения качественного чертежа, пригодного для чистовой печати. Чаще всего производится перемещение надписей названий выработок, накладывающихся друг на друга.

 

 

Для записи объектов, выводимых в рабочее графическое окно из БД вызывается диалог "Запись объектов отрисовки БД в файл-чертеж" (пункт меню Сервис/Выработки детальной разведки/Добавить в осн. файл-чертеж отрисовываемые элементы БД). Если в проекте нет ни одного файла-чертежа, упомянутый пункт меню будет неактивным.

 

В диалоге задается, какие из объектов, составляющих изображение, выводимое из БД в графическое окно, записать в текущий основной файл-чертеж: Названия выработок, Надписи у интервалов, Значки начала/конца выработок, засечки, Линии (полигоны) интервалов выработок.

 

Не обязательно записывать в файл-чертеж все объекты, формирующие графический образ информации из БД. Если проблема заключается только в наложении надписей названий выработок, можно записать в этот вспомогательный файл-чертеж только названия выработок. Затем отключить отрисовку названий выработок из БД и использовать названия, которые записаны в виде текстов во вспомогательном файле-чертеже, а остальная информация пусть по-прежнему выводится напрямую из БД.

 

В файл-чертеж записываются объекты из всех БД, которые отображаются в текущем активном рабочем графическом окне.
Если в файле-чертеже уже имеются какие-либо объекты, то они сохраняются без изменений, производится дозапись новых объектов.

 

 

Все объекты, записываемые в файл-чертеж размещаются в плоскости  окна: на разрезе – в плоскости текущего разреза, в окне плана – в плоскости текущего горизонта.

 
Полилинии и полигоны (в т.ч. значки начала выработок) записываются в абсолютных координатах в том виде (того размера), как они выглядят при текущем масштабе. При изменении масштаба они будут увеличиваться или уменьшаться. Поэтому перед записью объектов отрисовки БД следует установить масштаб равный тому, который будет в последующем при печати.

 
Текстовые надписи могут быть как масштабируемыми, так и одинакового размера во всех масштабах, в зависимости от того, задан ли базовый масштаб изображения в диалоге "Внешний вид выработок детальной разведки".

 

 

 

 

 

Например, имеется чертеж, на котором есть скважины, пробуренные из одного устья. Названия таких скважин накладываются друг на друга:

 

 

 

После сохранения названий выработок в файл-чертеж выполнена подвижка полученных текстовых надписей. На приводимом ниже рисунке отрисовка названий из БД отключена, названия выводятся из файла-чертежа, в который они были записаны, а остальные элементы выводятся из БД (хотя, конечно, можно было сохранить в файл чертеж и все отрисовываемые элементы и далее, для подготовки чертежа для печати, работать только с полученным файлом-чертежом):

 

 

 

 

 

 

Кроме описанной возможности записи в файл-чертеж проекций объектов, изображающих выработки БД на текущую плоскость, можно также записать в файл-чертеж выработки БД как трехмерные полилинии, а также устья выработок как маркшейдерские отметки.
См. пункты меню:
Сервис/Выработки детальной разведки/Добавить в осн. файл-чертеж выработки как полилинии и
Сервис/Выработки детальной разведки/Добавить в осн. файл-чертеж начала выработок как отметки.

 

 

 

 

Запись отрисовываемых объектов БД в файл dxf

 

Используя механизм записи отрисовываемых объектов БД в файл чертеж, можно далее произвести запись информации из этого файла-чертежа в файл dxf для работы с ним в Autocad (см. Экспорт в dxf-файл Autocad).

 

Следует обратить внимание на то, что если запись информации в файл-чертеж производилась при активном окне разреза, то и при записи в файл dxf необходимо, чтобы активным было окно с таким же разрезом. Объекты, получаемые при записи в файл-чертеж и в файл dxf будут плоскими (проецируются на плоскость текущего активного рабочего графического окна). Если запись информации в файл-чертеж производилась при активном окне плана, то, соответственно, и при записи в файл dxf необходимо, чтобы активным было окно плана.

 

Так как в Autocad при изменении масштаба изображения происходит пропорциональное изменение текстовых надписей, то целесообразно перед сохранением отрисовываемых объектов БД в файл-чертеж задать (для активного окна) базовый масштаб изображения и коэффициент влияния изменения масштаба относительно базового равным 1.0:

Тогда проще получить в Autocad текстовые надписи именно тех размеров, как они рисуются в окне DIGIMINE.

 

 

Рассмотрим пример записи отрисовываемых объектов БД в dxf-файл.

 

В окне разреза отрисовывается следующая информация из БД детальной разведки (фрагмент):

 

 

Создаем новый (пустой) файл-чертеж и делаем его основным.

Выбираем пункт меню Сервис/Выработки детальной разведки/Добавить в осн. файл-чертеж отрисовываемые элементы БД (предварительно убеждаемся, что активным является упомянутое выше окно разреза).

В диалоге "Запись объектов отрисовки БД в файл-чертеж" отмечаем все элементы.

После записи в файл-чертеж отключаем отрисовку из БД и производим необходимые корректировки изображения (в данном случае перемещение текстовых надписей).

В результате получаем (сейчас отрисовка производится уже не из БД, а из нового файла-чертежа, причем все изображаемые объекты являются плоскими):

 

 

Выбираем пункт меню Файл/Экспорт/Осн. файл-чертеж (mn4) в dxf-файл.

В диалоге "Экспорт файла-чертежа в dxf-файл" отмечаем запись в формат R2004, а также отмечаем Записывать 2D проекции объектов на плоскость активного рабочего графического окна.

Производим запись в dxf-файл.

 

В Autodesk DWG True view рассматриваемый фрагмент из этого файла выглядит следующим образом (на экране текстовые надписи немного отличаются, но если сделать более крупный масштаб, то различий практически не будет):