Справка DIGIMINE

ГЛАВНОЕ МЕНЮ для окон-чертежей

ГЛАВНОЕ МЕНЮ для окон-чертежей

Previous topic Next topic  

ГЛАВНОЕ МЕНЮ для окон-чертежей

Previous topic Next topic  

 

Главное меню программы изменяется, в зависимости от того, какое MDI-окно является активным - окно-чертеж или окно для работы с БД детальной разведки.  Для окна-чертежа главное меню программы содержит следующие пункты:

 

 

 

 

В главном меню почти нет пунктов, дублирующих элементы графических меню, а также нет дублирования тех пунктов меню, которые есть во всплывающих меню.
Такой подход принят для того, чтобы не перегружать меню обычного вида очень большим количеством элементов.

 

 

Пункт главного меню Файл:

 

 

 

Последние открытые файлы - вызов диалога, в котором можно просмотреть списки последних использованных файлов и открыть какой либо файл из файлов в имеющихся списках.

 

Новый файл – создание нового файла – вызов диалога "Выбор типа нового файла".

 

Открыть файл - открыть существующий файл, используемый программой DIGIMINE.

 

Сохранить все измененные файлы - запись на диск тех файлов (из файлов, загруженных в текущий проект) , в которых производилось редактирование, а также новых файлов, созданных в текущем сеансе работы с программой.

 

Сохранить все файлы - запись на диск всех файлов, загруженных в текущий проект, независимо от того, редактировались ли эти файлы.

 

 

Открыть проект… - открыть существующий файл проекта с одновременным открытием всех рабочих файлов, входящих в состав открываемого проекта. Предварительно производится проверка наличия измененных (или новых) не записанных на диск файлов текущего проекта. Если такие файлы имеются, будет предложено произвести запись их на диск.

 

Сохранить проект - запись на диск файла проекта и всех измененных рабочих файлов.

 

Сохранить проект как… - запись на диск файла проекта под другим именем, а также и всех измененных рабочих файлов.

 

 

Сохранить настройки в проекте по умолчанию - производится запись на диск, в файл проекта по умолчанию, настроек текущего загруженного проекта.

При простом запуске программы (без открытия какого-либо существующего проекта) происходит загрузка именно этого проекта по умолчанию, находящегося в файле default.prw (при наличии такого файла), располагающемся в том же разделе на диске, где находится программа (файл DIGIMINE.exe). Если же файла default.prw нет в том разделе, где находится программа, то при простом запуске программы создается проект с настройками по умолчанию.

 

 

 

Импорт - содержит следующие вложенные пункты меню:

 

 

 

 

          Полилиний (полигонов) из текстового файла... - Импорт файлов-чертежей - вызывается диалог выбора исходного текстового файла, а затем вызывается диалог "Импорт полилиний и полигонов из текстового файла".

 

 

         Моделей поверхностей (dgs) из dtm-файла Surpac - Производится чтение триангулированной модели поверхности из двух файлов с одинаковым названием и разными расширениями - dtm (описание треугольников) и str (исходные полилинии и точки). Подробнее...

 

 

         Моделей поверхностей (dgs) из dxf-файла - Производится чтение триангулированной модели поверхности из dxf-файла Autocad. Подробнее...

 

 

          Блочной модели (blo) из текстового файла... - Импорт блочной модели из текстового файла - вызывается диалог выбора исходного текстового файла, а затем вызывается диалог "Импорт блочной модели из текстового файла".

 

 

          Блочной модели (blo) из файлов bln, blm, rud... - Импорт блочной модели из файлов форматов bln, blm, rud - вызывается диалог выбора файла, производится чтение выбранного файла и преобразование в формат blo.

         К названию импортируемого файла добавляется информация о том, из файла какого формата он был получен. Например, после импорта файла "Блочная модель.bln" в проекте появится файл "Блочная модель(из bln).blo".

 

 

 

 

 

 

 

Экспорт - содержит следующие вложенные пункты меню:

 

 

 

         Описание различных видов экспорта из файла-чертежа приведено в разделе Экспорт файлов-чертежей в текстовые файлы.

 

         Описание различных видов экспорта из файла с триангулированными моделями поверхностей (объемных тел) приведено в разделе Чтение/запись моделей поверхностей.

 

         Осн. файл блочной модели (blo) в текстовый файл... - вызывается диалог "Экспорт блочной модели в текстовый файл".

 

 

 

 

Параметры чтения/записи файлов Datamine... - вызов диалога "Параметры чтения файлов Datamine (*.dm)".

 

 

Параметры чтения/записи dxf-файлов... - вызов диалога  "Параметры чтения/записи dxf-файлов".

 

 

 

 

 

Рамка документа - если этот пункт меню отмечен, то в окне-чертеже выводится рамка, показывающая область, предназначенную для печати. Этот пункт меню дублируется в графическом меню.
Для каждого окна-чертежа существует своя рамка документа, поэтому при изменении текущего активного окна-чертежа данный пункт меню может измениться, т.к. показывает, включена ли рамка документа именно для этого окна, а не для проекта в целом.

 

 

Рамку - в центр окна - рамка документа помещается в центр текущего активного рабочего графического окна.

Если текущее положение рамки документа находится за пределами рабочего графического окна, то после включения рамки документа (см. предыдущий пункт меню), ее изображение в окне не появляется.

Используя пункт меню Рамку - в центр окна мы перемещаем рамку документа в ту область, из которой выводится изображение в окно,

 

 

Печать... - вызов диалога "Печать".

 

 

 

Выход без сохранения проекта – выход из программы без сохранения файла проекта. Файлы текущего проекта будут закрыты с проверкой, сохранены ли изменения, сделанные в этих файлах.

 

Выход - выход из программы с записью на диск файла проекта. Файлы текущего проекта будут закрыты с проверкой, сохранены ли изменения, сделанные в этих файлах.

 

 

 

 

Пункт главного меню Сервис

 

 

 

 

 

Пункт меню Сервис / Файл-чертеж - содержит следующие вложенные пункты:

 

 

 

Преобразовать координаты объектов основного файла... - вызов диалога "Преобразование координат объектов файла-чертежа".

 

 

Преобразовать объекты в плане в объекты на разрезе... - вызов диалога "Преобразование чертежа разреза, введенного в плоскости XY".

 

 

Добавить все объекты из заданного файла в основной файл... - вызов диалога, в котором задается имя файла-чертежа, все объекты которого будут добавлены в текущий основной файл-чертеж.

 

 

Записать виртуальные линии, получившиеся в окне разреза, в основной файл - производится преобразование виртуальных полилиний, которые выводятся в текущем активном рабочем графическом окне разреза, в реальные полилинии и запись их в текущий основной файл-чертеж.

 

 

Записать виртуальные линии, получившиеся в окне плана, в основной файл - производится преобразование виртуальных полилиний, которые выводятся в текущем активном рабочем графическом окне плана, в реальные полилинии и запись их в текущий основной файл-чертеж.

 

 

Спроецировать полилинии и полигоны осн. файла на текущую модель поверхности - производится проецирование всех полилиний и полигонов из основного файла-чертежа на текущую модель поверхности.

Для 3D окон проецирование производится в том направлении, в котором пользователь смотрит на модель поверхности (т.е. перпендикулярно плоскости окна).

В местах пересечения отрезков полилиний (отрезков линии полигона) с ребрами треугольников модели поверхности производится добавление в полилинии новых точек.

 

То же, но без добавления точек пересечения с ребрами треугольников - производится проецирование ТОЛЬКО ТОЧЕК всех полилиний и полигонов из основного файла-чертежа на текущую модель поверхности.

Для 3D окон проецирование производится в том направлении, в котором пользователь смотрит на модель поверхности (т.е. перпендикулярно плоскости окна).

В местах пересечения отрезков полилиний (отрезков линии полигона) с ребрами треугольников модели поверхности новые точки НЕ ДОБАВЛЯЮТСЯ.

 

 

Преобразовать точки полилиний и полигонов (осн. ф.) в отметки - из точек полилиний и полигонов основного файла-чертежа формируются отметки и добавляются в этот же файл. Исходные полилинии и полигоны не изменяются.

 

 

Преобразовать в тексты комментарии полилиний (полигонов) осн. файла - в некоторых случаях может быть полезным преобразовать комментарии (а также номера) полилиний или полигонов в текстовые надписи. Например, если требуется экспортировать в Autocad информацию, записанную в комментарии полилиний (полигонов) в текстовом виде.

В текстовые надписи преобразуются те комментарии и номера полилиний (полигонов), отрисовка которых включена в активном рабочем графическом окне (см. диалог "Параметры отрисовки файлов-чертежей"). Запись текстовых надписей производится в текущий основной файл-чертеж, т.е. в тот же файл, в котором находятся полилинии (полигоны), комментарии которых преобразуются в текстовые надписи.

 

 

 

 

Пункт меню Сервис / БД разведочных выработок содержит следующие вложенные пункты:

 

 

 

Добавить в осн. файл-чертеж отрисовываемые элементы БД... - вызов диалога "Запись объектов отрисовки БД в основной файл-чертеж".

 

 

Добавить в осн. файл-чертеж выработки как полилинии - выработки БД детальной разведки (координаты устья и координаты точек из таблицы инклинометрии) преобразуются в полилинии и записываются в текущий основной файл-чертеж.

 

 

Добавить в осн файл-чертеж начала выработок как отметки - из координат устьев выработок БД детальной разведки формируются маркшейдерские отметки и добавляются в ттекущий основной файл-чертеж.

 

 

 

 

 

Пункт меню Сервис / Модели поверхностей (dgs) содержит следующие вложенные пункты:

 

 

 

 

Преобразовать координаты объектов основного файла... - вызов диалога "Преобразование координат моделей поверхностей".

 

 

Записать виртуальные линии, получившиеся в окне разреза, в основной файл-чертеж - производится преобразование виртуальных полилиний, получаемых при пересечении моделей поверхностей плоскостью текущего разреза, которые выводятся в текущем активном рабочем графическом окне разреза, в реальные полилинии и запись их в текущий основной файл-чертеж.

 

 

Записать виртуальные линии, получившиеся в окне плана, в основной файл-чертеж - производится преобразование виртуальных полилиний, получаемых при пересечении моделей поверхностей плоскостью текущего горизонта, которые выводятся в текущем активном рабочем графическом окне плана, в реальные полилинии и запись их в текущий основной файл-чертеж.

 

 

Обработка интервалов БД, центры которых попадают в каркасы - производится выбор интервалов из заданной таблицы БД, центры которых попадают внутрь заданных каркасов. Для каждого интервала, выбранного для расчетов, можно записать значение из заданного столбца таблицы с каркасами, соответствующее тому каркасу, в который попал интервал (произвести индексацию интервалов). в каркасы.

 

 

По выбранным интервалам для каждого каркаса могут  быть вычислены и записаны в соответствующие, создаваемые пользователем, столбцы таблицы с каркасами следующие значения: средневзвешенное значение; суммарный метрограмм (метропроцент); среднее значение; сумма; количество непустых интервалов; суммарная длина непустых интервалов; количество интервалов (включая возможные пустые интервалы); суммарная длина интервалов (включая возможные пустые интервалы).

 

При расчете средневзвешенного значения производится взвешивание на длину интервалов.

Имеется возможность задать другой столбец таблицы БД, значения которого использовать для взвешивания - например, столбец со значениями истинных мощностей интервалов. В этом случае добавляются еще 3 способа расчета: средневзвешенное (на истинную мощность); суммарный метрограмм (метропроцент) на истинную мощность; суммарная истинная мощность.

 

Подробнее - см. Обработка интервалов БД, попадающих в каркасы.

 

 

Переместить точки поверхностей осн. файла по нормалям ('расширить' / 'сузить' каркасы)... - Для каждой точки моделей поверхностей вычисляется вектор нормали, представляющий собой средневзвешенное значение из векторов нормалей треугольников, сходящихся в эту точку. Затем каждая точка перемещается на заданное расстояние в направлении вычисленной средневзвешенной нормали (если заданное расстояние больше нуля) или в направлении, противоположном этой нормали.

 

 

'Опустить' модели поверхностей их основного dgs-файла на точки из основного файла-чертежа... - Вычисляется вертикальное (по оси Z) расстояние от каждой исходной точки из файла-чертежа до модели поверхности. Затем для каждой точки модели поверхности рассчитывается вертикальное смещение (интерполяция методом обратных расстояний в степени) с использованием полученных расстояний от исходных точек до модели поверхности.

Например, можно получить поверхность четвертичных отложений, опустив модель поверхности исходного рельефа на точки подошвы четвертичных отложений, полученных по разведочным выработкам.

 

Подробнее - см.'Опускание' модели поверхности на точки

 

 

Разделить модели поверхностей из осн. dgs-файла на области... - может использоваться в том случае, когда требуется получить треугольники лежачего/висячего бока рудного тела, треугольники торцов каркасов и т.п.

В моделях поверхностей находятся группы треугольников со схожей ориентацией в пространстве. Производится разделение исходной модели поверхности на части, состоящие из этих групп.

 

Подробнее - см. Разделение моделей поверхностей на области

 

 

 

 

 

Пункт меню Сервис / Блочная модель содержит следующие вложенные пункты:

 

 

Добавить в основной файл-чертеж отрисовываемые элементы модели - этот пункт меню активен только для 2D графических окон.

Программа генерирует полилинии, полигоны и тексты, из которых состоит изображение текущей основной блочной модели, формируемое в текущем рабочем графическом окне и записывает сгенерированные объекты в текущий основной файл-чертеж.

Полученный файл-чертеж можно использовать при чистовом оформлении графики.

 

 

 

 

 

 

Пункт главного меню Вид

 

 

При помощи пунктов меню Вид производится настройка отрисовки различных объектов в рабочих графических окнах.

 

 

 

Вид изображения в окнах - вызывается диалог "Вид изображения в окнах" для определения того какого типа должны быть рабочие графические окна внутри активного окна-чертежа. Если 2D, то план или разрез (независимые или связанные); если 3D, то ортогональная проекция или перспективная и т.д.

Это один из немногих пунктов меню, который дублируется в графическом меню.

 

Полилинии, полигоны, отметки... - вызывается диалог "Параметры отрисовки объектов файлов-чертежей".

 

 

Точки файла-чертежа... - вызывается диалог "Параметры отрисовки точек из файлов-чертежей".

 

Полилинии разделения уступов... - вызывается диалог "Параметры отображения полилиний разделения уступов в окне".

 

Полилинии оптимального карьера... - вызывается диалог "Параметры полилиний оптимального карьера".

 

БД разведочных выработок (dew)... - вызывается диалог "Внешний вид выработок детальной разведки".

 

Модель поверхности (dgs)... - вызывается диалог "Параметры моделей поверхностей (объемных тел)".

 

 

Блочная модель (blo)... - в зависимости от вида изображения в рабочем графическом окне, для которого производится настройка, вызывается один из трех диалогов :

- "Параметры отрисовки блочной модели в 2D окне плана";

- "Параметры отрисовки блочной модели в 2D окне разреза";

- "Параметры отрисовки блочной модели в 3D окне".

 

 

Параметры 3D окна... - вызывается диалог "Параметры 3D-окна".

 

Центрирование окна... - вызывается диалог "Перемещение центра окна". Это один из немногих пунктов меню, который дублируется в графическом меню.

 

 

 

 

Пункт главного меню Параметры

 

 

Справочник типов полилиний... - вызывается диалог "Параметры полилиний по умолчанию".

 

Справочник типов полигонов... - вызывается диалог "Параметры полигонов по умолчанию".

 

Справочник типов точек ... -

 

Параметры редактирования файлов-чертежей... -  вызывается диалог "Параметры редактирования файлов-чертежей".

 

Параметры объединения полилиний... - вызывается диалог "Параметры объединения полилиний".

 

Параметры перерисовки... - вызывается диалог "Параметры перерисовки в графических окнах".

 

Параметры сглаживания/упрощения полилиний... - вызывается диалог "Параметры сглаживания/упрощения полилиний, построения съездов".

 

Параметры векторизации полилиний... - вызывается диалог "Параметры векторизации полилиний".

 

Параметры координатной сетки... - вызывается диалог "Параметры координатной сетки".

 

 

 

 

 

Пункт главного меню Мозаика из 2-х окон...

 

Этот пункт меню сделан самостоятельным пунктом главного меню для обеспечения быстрого доступа к нему (такой же пункт меню есть и внутри подпунктов пункта главного меню Окно).

Назначение этого пункта меню - размещение внутри главного окна двух MDI-окон, с разделением рабочей области главного окна  программы пополам.

Если в текущий момент времени в программе используется два MDI-окна, размещение этих окон производится сразу же после выбора пункта меню.

Если количество MDI-окон больше двух, то вызывается диалог, в котором выбирается второе MDI-окно. Первым окном считается текущее активное MDI-окно.

 

 

 

Пункт главного меню Окно

 

 

 

Граф. меню - по ширине окна. - По умолчанию, если элементы графического меню не помещаются в окно, то те, которые находятся в правой части, не рисуются. Если рассматриваемый пункт меню отмечен, то при малой ширине окна добавляются дополнительные строки графического меню, чтобы рисовались все элементы графического меню.

 

Во всех диалогах - мелкий шрифт - В том случае, если экран имеет небольшое разрешение (например, 800х600), можно задать, чтобы во всех окнах диалогов использовался мелкий шрифт, что уменьшает размеры окон диалогов.

В большинстве случаев нет необходимости включать этот пункт меню, тем более, что для самых больших диалогов программа автоматически уменьшает размер шрифта, если обнаруживает небольшое разрешение экрана.

 

 

Создать новое окно-чертеж - создается новое окно чертеж. Следует обратить внимание на то, что создаваемое окно-чертеж наследует все настройки, которые имеет текущее активное окно-чертеж (и его рабочие графические окна).

 

 

Изменить название окна. - При создании нового окна-чертежа ему присваивается название "Чертеж N", где N - порядковый номер. Кроме того, в названии окна присутствует информация о виде изображения в окне ( <разрез/план>, <план>, <3D ортог.> и т.п.). При помощи рассматриваемого пункта меню вызывается диалог, в котором можно изменить название текущего окна.

 

 

Очистить окно с информацией о работе программы - при выборе этого пункта меню производится очистка вспомогательного окна с информацией о работе программы.

 

В нижней части меню Окно присутствует список имеющихся MDI-окон (окон-чертежей и окон для работы с БД детальной разведки).

Текущее окно отмечено галочкой. Выбор окна из этого списка делает его активным.

 

 

 

 

Пункт главного меню Справка